CodeIgniter 3.0 will support PHP 5.2. Anthony Ferrara wrote an interesting article on his blog why that's a very bad thing.

http://blog.ircmaxell.com/2014/12/on-php-version-requirements.html